XaMp.imomo.net Forum Index XaMp.imomo.net
support forums for XaMp studio edition and XaMp desktop
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Initial observations

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    XaMp.imomo.net Forum Index -> studio edition bug reports
View previous topic :: View next topic  
Author Message
pike



Joined: 21 Jul 2005
Posts: 8

PostPosted: Sun Mar 26, 2006 8:12 am    Post subject: Initial observations Reply with quote

Just downloaded it and played around for about 20 minutes. I love it so far! Looks like it's going to be a great follow-up to XaMp Desktop.

Here are some obvious bugs that I noticed right away:

-Preferences are not being saved
-Window locations not remembered when the program is closed
-The "artist info" and "buy track" links do not obey user's default browser
-Channel list opens off screen (way at the bottom of my primary monitor). In order to find it, I must increase my resolution to the max and drag the channel window to the main xamp window (note: I have 3 monitors if this helps)
-Does not remember which windows user had open when they closed the program. Always opens only the main window (this may or may not be a bug)
-Prefs window opens off screen. There's just enough of it on my primary monitor to drag it back into view, but still annoying.
-imomo.net tracker does not work. Have not tried the others. May be related to prefs not saving issue above.
-Loading/saving preset values does not work. May not be implemented yet.

Other than that, the program is totally usable and I'm lovin it so far! It seems to run much faster (opening/closing, log in, channel changes, etc)

-Mike
_________________

Back to top
View user's profile Send private message
m0mo
Site Admin


Joined: 17 Jun 2005
Posts: 134

PostPosted: Mon Mar 27, 2006 9:59 pm    Post subject: Re: Initial observations Reply with quote

-Preferences are not being saved

preferences should be saved by clicking the close button. the X does not save preferences. (but this will be fixed in the new beta) which prefs are not being saved?

-Window locations not remembered when the program is closed

this feature is added in the new version

-The "artist info" and "buy track" links do not obey user's default browser

i am currently looking into this bug

-Channel list opens off screen (way at the bottom of my primary monitor). In order to find it, I must increase my resolution to the max and drag the channel window to the main xamp window (note: I have 3 monitors if this helps)

this relates to the other window location problem

-Does not remember which windows user had open when they closed the program. Always opens only the main window (this may or may not be a bug)

this was not a bug, but i have added this feature now

-Prefs window opens off screen. There's just enough of it on my primary monitor to drag it back into view, but still annoying.

this relates to previous problem

-imomo.net tracker does not work. Have not tried the others. May be related to prefs not saving issue above.

are you using your forum username and password? your tracker image should be http://xamp.imomo.net/tracker/pike/tracker.png

-Loading/saving preset values does not work. May not be implemented yet.

preset values should be loaded. it loads the first 8 from xmradio and the rest are stored locally on the computer. are none being loaded? how many do you have on xmradio.com?
Back to top
View user's profile Send private message Send e-mail
pike



Joined: 21 Jul 2005
Posts: 8

PostPosted: Tue Mar 28, 2006 6:00 pm    Post subject: Reply with quote

Prefs are saving now. It seems as though in order to make them save, you have to enter the info, click on "skins" and then click back before you press "close". It's a little touchy.

The tracker problem is with the wording in the beta. The URL displayed in the prefs screen is:

Code:

http://xamp.imomo.net/<username>/tracker.png


should be, as you pointed out:

Code:

http://xamp.imomo.net/tracker/<username>/tracker.png


And when I was describing the presets issue, I omitted the fact that I was talking about the EQ presets, sorry.

thanks again for the great program!

-Mike
_________________

Back to top
View user's profile Send private message
m0mo
Site Admin


Joined: 17 Jun 2005
Posts: 134

PostPosted: Tue Mar 28, 2006 6:26 pm    Post subject: Reply with quote

sorry for the typo for the tracker url. it has been updated for the next release.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    XaMp.imomo.net Forum Index -> studio edition bug reports All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group